Journey to the CCIE LAB – Part 44 – BGP Link Bandwidth

I have been out of ” circulation” for sometime due to laziness,facebook(soo addictive) and lots of work-related stuff..But am now back :(..No more excused from me.
As i get to proceed with my CCIE studies i have been comming across many concepts on the same and they are quite interesting.One of the is using of the BGP Link bandwidth as weight.

Here is some reading I got from Cisco and the lab I simulated to capture the same.

The BGP Link Bandwidth feature used to enable multipath load balancing for external links with unequal bandwidth capacity. This feature is enabled under an IPv4 or VPNv4 address family sessions by entering the bgp dmzlink-bw command. This feature supports both iBGP, eBGP multipath load balancing, and eiBGP multipath load balancing in Multiprotocol Label Switching (MPLS) Virtual Private Networks (VPNs). When this feature is enabled, routes learned from directly connected external neighbor are propagated through the internal BGP (iBGP) network with the bandwidth of the sourceexternal link.

The link bandwidth extended community indicates the preference of an autonomous system exit link in terms of bandwidth. This extended community is applied to external links between directly connected eBGP peers by entering the neighbor dmzlink-bw command. The link bandwidth extended community attribute is propagated to iBGP peers when extended community exchange is enabled with the neighbor send-community command.

Benefits of the BGP Link Bandwidth Feature

The BGP Link Bandwidth feature allows BGP to be configured to send traffic over multiple iBGP or eBGP learned paths where the traffic that is sent is proportional to the bandwidth of the links that are used to exit the autonomous system. The configuration of this feature can be used with eBGP and iBGP multipath features to enable unequal cost load balancing over multiple links. Unequal cost load balancing over links with unequal bandwidth was not possible in BGP before the BGP Link Bandwidth feature was introduced.

Prerequisites for BGP Link Bandwidth
• BGP load balancing or multipath load balancing must be configured before this feature is enabled.
• BGP extended community exchange must be enabled between iBGP neighbors to which the link bandwidth attribute is to be advertised.
• Cisco Express Forwarding (CEF) or distributed CEF (dCEF) must be enabled on all participating routers.

Restrictions for BGP Link Bandwidth
• This feature can be configured only under IPv4 and VPNv4 address family sessions.
• BGP can originate the link bandwidth community only for directly connected links to eBGP neighbors.
• Both iBGP and eBGP load balancing are supported in IPv4 and VPNv4 address families. However, eiBGP load balancing is supported only in VPNv4 address-family.

LAB CONFIGS :

RA

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
no ip address
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 10
router-id 1.1.1.1
log-adjacency-changes
network 10.10.10.0 0.0.0.255 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 10.10.10.2 remote-as 100
neighbor 10.10.10.3 remote-as 100
maximum-paths ibgp 6
!
address-family ipv4
neighbor 10.10.10.2 activate
neighbor 10.10.10.2 send-community both
neighbor 10.10.10.2 next-hop-self
neighbor 10.10.10.3 activate
neighbor 10.10.10.3 send-community both
neighbor 10.10.10.3 next-hop-self
maximum-paths ibgp 6
no auto-summary
no synchronization
bgp dmzlink-bw
exit-address-family

RB

!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.10.10.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
bandwidth 500
ip address 172.16.1.2 255.255.255.0
encapsulation ppp
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
bandwidth 1733
ip address 172.16.2.2 255.255.255.0
encapsulation ppp
clock rate 2000000
!
router ospf 10
router-id 2.2.2.2
log-adjacency-changes
network 10.10.10.0 0.0.0.255 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 10.10.10.1 remote-as 100
neighbor 10.10.10.3 remote-as 100
neighbor 172.16.1.1 remote-as 200
neighbor 172.16.2.1 remote-as 200
maximum-paths 6
maximum-paths ibgp 6
!
address-family ipv4
neighbor 10.10.10.1 activate
neighbor 10.10.10.1 send-community both
neighbor 10.10.10.1 next-hop-self
neighbor 10.10.10.3 activate
neighbor 10.10.10.3 next-hop-self
neighbor 172.16.1.1 activate
neighbor 172.16.1.1 dmzlink-bw
neighbor 172.16.2.1 activate
neighbor 172.16.2.1 dmzlink-bw
maximum-paths 6
maximum-paths ibgp 6
no auto-summary
no synchronization
bgp dmzlink-bw
exit-address-family
!
ip forward-protocol nd
ip route 172.16.1.0 255.255.255.0 172.16.1.1
ip route 172.16.2.0 255.255.255.0 172.16.2.1
!

RC

!
interface FastEthernet0/0
ip address 10.10.10.3 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
bandwidth 5000
ip address 172.16.3.31 255.255.255.0
encapsulation ppp
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 10
router-id 3.3.3.3
log-adjacency-changes
network 10.10.10.0 0.0.0.255 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 10.10.10.1 remote-as 100
neighbor 10.10.10.2 remote-as 100
neighbor 172.16.3.30 remote-as 200
maximum-paths 6
maximum-paths ibgp 6
!
address-family ipv4
neighbor 10.10.10.1 activate
neighbor 10.10.10.1 send-community both
neighbor 10.10.10.1 next-hop-self
neighbor 10.10.10.2 activate
neighbor 10.10.10.2 send-community both
neighbor 10.10.10.2 next-hop-self
neighbor 172.16.3.30 activate
neighbor 172.16.3.30 dmzlink-bw
maximum-paths 6
maximum-paths ibgp 6
no auto-summary
no synchronization
bgp dmzlink-bw
exit-address-family
!
ip forward-protocol nd
ip route 172.16.3.0 255.255.255.0 172.16.3.30
!
!

RD

!
interface FastEthernet0/0
ip address 172.17.17.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
bandwidth 500
ip address 172.16.1.1 255.255.255.0
encapsulation ppp
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router eigrp 10
network 172.17.0.0
no auto-summary
!
router bgp 200
no synchronization
bgp log-neighbor-changes
network 192.168.1.0
neighbor 172.16.1.2 remote-as 100
neighbor 172.17.17.1 remote-as 200
neighbor 172.17.17.1 next-hop-self
neighbor 172.17.17.3 remote-as 200
neighbor 172.17.17.3 next-hop-self
no auto-summary
!
ip forward-protocol nd
ip route 172.16.1.0 255.255.255.0 172.16.1.2
!
!

RE
!
interface FastEthernet0/0
ip address 172.17.17.3 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
bandwidth 5000
ip address 172.16.3.30 255.255.255.0
encapsulation ppp
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
bandwidth 1733
ip address 172.16.2.1 255.255.255.0
encapsulation ppp
clock rate 2000000
!
router eigrp 10
network 172.17.0.0
no auto-summary
!
router bgp 200
no synchronization
bgp log-neighbor-changes
neighbor 172.16.2.2 remote-as 100
neighbor 172.16.3.31 remote-as 100
neighbor 172.17.17.1 remote-as 200
neighbor 172.17.17.1 next-hop-self
neighbor 172.17.17.2 remote-as 200
neighbor 172.17.17.2 next-hop-self
no auto-summary
!
ip forward-protocol nd
ip route 172.16.2.0 255.255.255.0 172.16.2.2
ip route 172.16.3.0 255.255.255.0 172.16.3.31
!

RF

!
interface Loopback1
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 172.17.17.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 10
network 172.17.0.0
no auto-summary
!
router bgp 200
no synchronization
bgp log-neighbor-changes
neighbor 172.17.17.2 remote-as 200
neighbor 172.17.17.2 next-hop-self
neighbor 172.17.17.3 remote-as 200
neighbor 172.17.17.3 next-hop-self
no auto-summary
!

Advertisements

About CCIE R&S :- IP/MPLS Networks Consultant

>>>A full CCIE (R&S) from March 18th 2013 >>>Passionate about IP networks. >>>>A consultant plying his trade across the world. >>> Currently digging deeper and deeper into Network Automation with Python Language
This entry was posted in Uncategorized. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s